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[MITSUMI Sensor Shield Kit for Arduino] User’s Guide:

Instruction Manual

OUTLINE

This document is the instruction manual of "MITSUMI Sensor Shield Kit for Arduino”.

“MITSUMI Sensor Shield Kit for Arduino” is a kit consisting of the Shield for Arduino, which is supposed to be used by
connecting to Arduino, and the Sensor board equipped with various sensors. You can easily check the operation of the
sensors by using Sample Sketch for each sensor.

For details on each sensor, refer to the applicable data sheet.
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1 Configuration

“MITSUMI Sensor Shield Kit for Arduino” consists of Shield, Sensor boards, Cables (I2C, SPI), and Sample Sketch.
Arduino itself is not included in this kit.

Shield Sensor Board Cable Sample Sketch

2 Usage form

This kit is used by connecting the Shield to user’s Arduino. Using Sample Sketch allows you to check operations of each
sensor.

\

Cable (12C)

Shield

USB Cable

PC

Arduino UNO Sensor Board
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3 Compatible Arduino models
This kit is applicable to UNO, LEONARDO, DUE, and MEGA2560.

Model UNO LEONARDO DUE MEGA2560
View
System
Power 5.0V 5.0V 3.3V 5.0V
Supply

4 Block diagram

PC Arduino

3.3V

50V

usB

12C

SPI

Sensor Board
*MMR902-12C
*MMR920-12C

Shield
3.3V
LI
O
O
50V
Jumper 12C Connector
33Vor50Vy 3.3Vy 3.3V _ _
p 12C (5.0V or 3.3V; PCA9517DP < 12C(3.3V >le >
Cable (I12C)
Level Shifter
SPI Connector
3.3Vor5.0Vy 3.3V, 3.3V . >
Cable (SPI)
Level Shifter

Sensor Board
*MMR902-SPI
*MMR906

*MMR920-SPI
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5 How to use the Sensor Shield Kit

An example connection is given below. In this example, the Sensor board of the gauge pressure sensor (MMR920C04)
and Arduino Uno are used.

(1) Connect the Arduino UNO and the Shield.

(2) Connect the system power switch jumper to 5V pin.

(3) Connect I2C connector (CN104) on the Sensor board of MMR920C04 and I2C connector (CN5) on the Shield using an
I2C cable.

(4) Connect the Arduino UNO and the PC using an USB cable.

\

Cable (I2C) —e

USB Cable
D= )
| | e\
= Power switching
Jumper Arduino UNO Sensor Board (MMR920C04)

(5) Launch Arduino IDE.

(6) Recognize the Arduino UNO on the Arduino IDE.

Select [Tools] -> [Board: "Arduino Uno”] -> [Arduino Uno].
@ sketch_apr26a | Arduino 1.8.19 - m] X

File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch

Boards Manager..
Fix Encoding & Reload

sketch_apr26g

void setup() Manage Libraries... Ctrl+Shift+| A ~
//BRE ST o) Monitor CtrlShifts M Arduine Yin
' Serial Plotter Chri+Shift=L || % Arduine Uno

Arduino Duemilanove or Diecimila
WiFi101 / WiFiNINA Firmware Updater

void loop() || Arduino Nano
HPRE VRN g "Arduing Uno® §  Arduino Mega or Mega 2560
} Port 1 Arduino Mega ADK
Get Board Info Arduino Leonardo

Arduino Lecnardo ETH
Programmer: "AVRISP mkl"
Arduino Micro
Burn Bootloader .
Arduino Esplora
Arduino Mini
Arduino Ethernet
Arduino Fio
Arduino BT

LilyPad Arduino USB v

Select [Tools] -> [Port] -> [COMxx (Arduino Uno)].
The port number (COMxx) differs depending on the PC.

@ sketch_apr26a | Arduino 1,819 — [m] x
File Edit Sketch Toaols Help

Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload

sketch_apr26g

void setup() Manage Libraries... Crl+Shift1 -
7/ BUE YOI gerial Monitor Ctrl+Shift=M
1 Serial Plotter Ctrl+Shift+L
soia teopqy (| WIFIIO/ WIFININA Frmiwore Updater
A aE yeun g "Arduino Uno® >
, Port | ot
Get Board Info coms

COMS (Arduine Uno)
Programmer: "AVRISP mkll"

Burn Bootloader
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(7) Open the Sample Sketch on the Arduino IDE.

Select [File] -> [Open...] -> [Mitsumi_Sensor_Shield_Kit_ MMR920_I2C_Sample_Sketch.ino].

@ sketch_spr26a | Arduino 1.8.19
File Edit Sketch Tools Help

Quit

New Ctrl+N
Open... Ctrl+0
Open Recent

Sketchbook

Examples

Close Ctrl+W

Save Ctrl+S

Save As... Ctrl+Shift+5
Page Setup  Ctrl+Shift+P
Print Ctrl+P
Preferences  Ctrl+Comma

Ctrl+Q

re, to run o

€, TO run rej

| %] Open an Arduino sketch...

Look n: |

Mitsum_Sensor_Shield_Ki_MMR320_2C_S: ~| @ ¥ [* [@~

- MName
*

Date modified

Quick access

Desktop

Libraries

‘.

5
&
5
3

&

Metwork

Object name:

Objects of type:

ch.ino. 4/28/2022 4:51 PM

Mitsumi_Sensor_Shield_Kit_MMR320_|2C_Sample_Sketch.ino ~ |

Open

Al Files (") ~

Cancel

(8) Verify the Sample Sketch on the Arduino IDE.
Click [Verify] button to check whether an error occurs.

@ Mitsumi_Sensor_Shield_Kit_ MMR320_12C_Sample_Sketch | Arduino 1.8.19 - m] X
File Edit Sketch Tools Help
Witsumi_Sensor_Shisld_Kit_MMR920_I2C_Sample_Sketch
1 ~
1
12 // INCLUDES
13 /7
14 #include <Wirs.h>
:: s
17 // DEFINES AND MACROS for Arduino Sertings
18 /F
19 gdefine UNO 1
20 #ds 2
21 #ds 3
22 gdefine MEGA2580 4
23 gdefine ARDUINO_VER UNO
(9) Upload the Sample Sketch to the Arduino UNO on the Arduino IDE.
Click [Upload] button to upload the Sample Sketch.
<] Mitsumi_Sensor_Shield_Kit_MMRI20_12C_Sample_Sketch | Arduino 1,819 — [m] x
File Edit Sketch Teels Help
Mitsumi_Sensaor_Shield_Kit MMR920_I2C_Sample_Sketch
~

11 /f
12 // INCLUDES
13 /7
#include <Wire.h>

I
7 /f DEFINES RND MACROS for Arduinc Sertings
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(10) Check the output data on the serial monitor.
Select [Tools] -> [Serial Monitor].

@ Mitsumi_Sensor_Shield_Kit MMR920_I2C_Sample_Sketch | Arduino 1.8.13

- ] X

| Mitsumi_Sens

File Edit Sketch Tools Help

14 g#include 'owrrc

Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload

A

Manage Libraries... Ctrl+Shift+|
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

Board: "Arduino Uno" >
Port: "COM16 (Arduine Uno)" >
Get Board Info

Programmer: "AVRISP mkil" b

Burn Bootloader

18 /f:

17 // DEFINES AND MACROS for Arduino Settings

The data is output to the serial monitor. The delimiter and baud rate should be as follows.
The data is displayed in the following order: measurement interval [usec], measurement data (temperature [°C],
pressure [cmH20])

@ comie

Send

3212,27.289,0.008
3208,27.289,0.008
3208,27.289,0.007
3212,27.289,0.007
3208,27.289,0.008
3212,27.289,0.008
3208,27.289,0.007
3212,27.289,0.008
3208, 27.

3208
3212
3208,27.289,0.008
3212,27.289,0.007
3212,27.289,0.008
3212,27.289,0.008

- Delimiter: Newline

/ -Baud rate: 115200

Autoscroll [] Show timestamp

v
I Newline ~ | 115200 baud Clear output

6 Shield

6-1 Description
The Shield has connectors to connect to Arduino (CN21 to CN25) in its peripheral area and those to connect to the

Sensor board (I2C connectors: CN1 to CN9, SPI connectors: CN10 to CN11, interrupt connector: CN12) in its center.
The size of the Shield is 55.88 x 53.34 mm.

CN1 CN2 CN3
JP1
CN4 CN6
CN5
CN7 CN9
CN8

CN10 CN11 CN12
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6-2 Connector
JP1: System power switch jumper

View Pin | Name Function Note

1 3.3V 3.3 V supplied from the Arduino. | Sensor power supply

- During use of UNO, LEONARDO, or MEGA2560
-> Connected to 5.0 V pin.

- During use of DUE
-> Connected to 3.3 V pin.

2 VDD System power supply

3 50V 5.0 V supplied from the Arduino.

Set the jumper according to the system power supply of the Arduino. For the system power supply, refer to the
compatible models. If the jumper setting is wrong, the communication between the Arduino and each sensor may fail.

CN1 - CN9: I2C connector

View Pin | Name | Function Note
1 SCL 2C Connected to CN25 SCL pin.
2 SDA Connected to CN25 SDA pin.
3 VDD 3.3 V (sensor power supply) —
4 GND Ground —

CN10, CN11: SPI connector

View Pin | Name Function Note

SPI1: Connected to CN24 D7 pin.

1 CsB SPI2: Connected to CN24 D6 pin.
2 SCLK SPI Connected to CN23 SCLK pin.

3 MOSI Connected to CN23 MOSI pin.

4 MISO Connected to CN23 MISO pin.

5 VDD 3.3 V (sensor power supply) —

6 GND Ground —

CSB pin of SPI1 connector and that of SPI2 connector are connected to different pins of the Arduino.

CN12: Interrupt connector

View Pin | Name | Function Note
Connected to CN24 D3 pin.
1 INT1 Interrupt or Digital input Connect TH on the Sensor board to use DRDY /
i DRDYB signal of the sensor.
m Connected to CN24 D2 pin.
2 INT2 Interrupt or Digital input Connect TH on the Sensor board to use DRDY /
DRDYB signal of the sensor.

MITSUMI ELECTRIC CO., LTD.
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7 Sensor Board

7-1 Description
For the Sensor board, the IF depends on the mounted sensor. The size of this board is 20 x 24 mm.

Sensor I2C SPI Note
- Digital output gauge pressure sensor
- Operating range: 0 to +300 mmHg
MMRO902A34A - Operating range: 0 to +50°C
- I2C Address: 0xCA(W)/0xCB(R)
] ! - Data Sheet: MMR902A34A_DATASHEET_Rev.0
MITSUMI g HRS0
MMR902A34A
CN103
o CNICI3 » «
u@w'_s - Digital output gauge pressure sensor
MMROOEXAN _ oM EBRB & : - Operat!ng range: -40 to +.’260 mmHg
wes o e e - Operating range: 0 to +60°C
» [T Wk Cl08 - Data Sheet: MMRO06XAN_DATASHEET_Rev.0
MITSUMI MMRS06
MMR906XAN
- Digital output micro-pressure sensor
e IR - Operating range: -40 to +40 cmH20
MMR920C04 T - Operating range: 0 to +50°C
" - 12C Address: 0xCE(W)/0xCF(R)
- Data Sheet: MMR920_DATASHEET_Rev.1.1
MMR920C4

7-2 Connector
CN101, CN104, CN106: I2C connector

View Pin | Name | Function Note
—-1 SCL C Connected to SCL pin of the sensor.
%4 £ SDA Connected to SDA pin of the sensor.

VDD 3.3 V (sensor power supply) -

AWIN|—=

GND Ground —

CN102, CN103, CN105: SPI connector

View Pin | Name | Function Note
1 CSB Connected to CSB pin of the sensor.
2 SCLK SPI Connected to SCLK pin of the sensor.
3 MOSI Connected to SDI pin of the sensor.
4 MISO Connected to SDO pin of the sensor.
5 VDD 3.3 V (sensor power supply) —
6 GND Ground —

TH: Through-hole

View Pin | Name | Function Note
1 DRDYB | Digital output Connect to CN12 on the Shield to use DRDYB or
Ty (DRDY) | (Data Ready signal) DRDY signal of the sensor.

MITSUMI ELECTRIC CO., LTD.
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8 Schematic Circuit Diagram
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9 Sample Sketch

Sensor board | Interface File Name

MMR902_I2C 12C Mitsumi_Sensor_Shield_Kit_ MMR902_I12C_Sample_Sketch.ino
MMR902_SPI SPI Mitsumi_Sensor_Shield_Kit_ MMR902_SPI_Sample_Sketch.ino
MMR906 SPI Mitsumi_Sensor_Shield_Kit_ MMR906_SPI_Sample_Sketch.ino
MMR920_I2C 12C Mitsumi_Sensor_Shield_Kit_ MMR920_I2C_Sample_Sketch.ino
MMR920_SPI SPI Mitsumi_Sensor_Shield_Kit_ MMR920_SPI_Sample_Sketch.ino

* Operation check using Arduino IDE 1.8.19.

9-1 How to change Arduino model

In the Sample Sketch, the code for UNO is initially set.
Change the code given below according to the Arduino model to use.

I Mitsumi_Sensor_Shield_Kit_MMRI02_I2C_Sample_Sketch _

12 /¢ INCLUDES

lude <iire.h>

AND MACROS for Arduino Settings

/- For use of Arduino UNO
23 #defines ARDUINO VER O
< *For use of Arduino DUE

23 #defins ARDUINO VER LUE
*For use of Arduino LEONARDO

23 fﬂefine ARDUINC VER LECHARDO
*For use of Arduino MEGA2560

23 #defins ARDUINC VER  MEGA2560

9-2 How to change SPI connector

In the Sample Sketch, the code for CN10 SPI1 connector is initially set.

To make the Sample Sketch to be used for CN11 SPI2 connector, change the code given below.

Mitsumi_Sensor_Shield_Kit MMR902_SP1_Sample_Skeich _

INCLUDES

nclude <SPI.h>

ne SPI_SELECT SPI1 I /f select S5PI Connector

-For use of CN10 SPI1 connector
44 #define SPI_SELECT SPIl

*For use of CN11 SPI2 connector
14 #define SPI_SELECT SPI2

f/ select 5PI Connector

'/ select 5PI Connector

MITSUMI ELECTRIC CO., LTD.
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9-3 How to change the delimiter
Data output of the Sample Sketch is initially comma-separated.

To change the delimiter, change the character between double quotations to the desired character as shown below.

~

12 // INCLUDES

4 #include <Wire.h>

- Use of comma_
92 char sep[2] = ",";

- Use of semicolon

ar sep[2] = ;"

9-4 Serial Monitor Settings

The Sample Sketch outputs the measurement data and the measurement intervals by serial communication.

The measurement data can be confirmed on the serial monitor.

@ coms - O X

Send

18 ]]4 0.259
16000,0.265
16000,0.248
16000,0.250
16004,0.258
16004,0.261
16000,0.260

16004,0.251
Teu00, 0. 455
18004,0.258
16004,0.25¢
16004,0.260
18000,0.261
16000,0.25%
16004,0.254
18004 _n 253

v
>

Autoscroll ] Show timestamp

Newline v | |HIE ~ Clear output

Measurement interval [usec]

’

N

Louuug,
16000,
16004,
16004,
16000,
16004,

leg000,
la004,

/

U. 24D
0.250
0.258
0.28l
0.2e0
0.251
0.258
0.258

3

Measurement data

Setting of the serial communication is as shown below. The data can be confirmed by multi-purpose terminal software

and others.

Serial communication setting

Item Setting Value
Baud rate 115,200 bps
Data length 8 bits
Parity None
Stop bit 1 bit
Transfer Direction LSB First
Delimiter LF

9-5 Download of Arduino IDE

The Arduino IDE is required to upload the Sample Sketch to the Arduino. Download the Arduino IDE from the URL

below.
https://www.arduino.cc/en/software

MITSUMI ELECTRIC CO., LTD.
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Important notice for users of this material

1. Thisis a reference material for Mitsumi products users. This does not grant users any rights to use
or practice intellectual property or other rights with regard to engineering information contained in
this material, owned by Mitsumi Electric Co., Ltd.

2. We will assume no responsibility for any loss or any infringement of third party's rights, resulting
from the information provided in this material.

3. All information provided in this material is as of the issue date of the material. Please note that the
products and specifications mentioned in this material are subject to change without prior notice.
Please check the latest information before purchasing Mitsumi's products, and let you keep up to
date with information posted on our website.

4. Although the information contained in this material is carefully produced to ensure accuracy, we will
assume no responsibility for any loss incurred by customers, arisen from any incorrect information
found in this material.

5. When you use the engineering information, programs, or algorithms provided in this material for
your purpose, please fully evaluate an overall system but not individually evaluate product alone,
engineering information, programs, and algorithms before application. We will assume no
responsibility for your decision for application.

6. The design and manufacturing of the product mentioned in this material are not intended for

applications in devices or systems used under which is harmful to human's life.

Our prior-permission is required for any reprint or reproduction of this material.

8. Please contact us for further details of this material, and let us know your comments, if any.

N

[Contact]

Mitsumi Electric Co., Ltd.
Semiconductor Division, Design Engineering Department

1601, Sakai, Atsugi-shi, Kanagawa, 243-8533 JAPAN
TEL:046-230-3367
URL : http://www.mitsumi.co.jp/profile/contact.html

MITSUMI ELECTRIC CO., LTD.


http://www.mitsumi.co.jp/profile/contact.html

	1  Configuration
	2 Usage form
	3 Compatible Arduino models
	4 Block diagram
	5 How to use the Sensor Shield Kit
	6 Shield
	6-1 Description
	6-2  Connector

	7 Sensor Board
	7-1 Description
	7-2 Connector

	8 Schematic Circuit Diagram
	8-1 Shield
	8-2 Sensor Board

	9 Sample Sketch
	9-1 How to change Arduino model
	9-2 How to change SPI connector
	9-3 How to change the delimiter
	9-4 Serial Monitor Settings
	9-5 Download of Arduino IDE


